Bug 20437: Update debian/control
[koha_ffzg] / debian / list-deps
index f12d088..83e28bf 100755 (executable)
@@ -17,8 +17,7 @@
 # You should have received a copy of the GNU General Public License
 # along with this program.  If not, see <http://www.gnu.org/licenses/>.
 
-use strict;
-use warnings;
+use Modern::Perl;
 
 use C4::Installer::PerlDependencies;
 
@@ -26,7 +25,11 @@ use C4::Installer::PerlDependencies;
 # apt-file can find, e.g. in the Koha repo rather than the regular
 # debian one.
 my %overrides = (
-    'LWP::Protocol::https' => 'liblwp-protocol-https-perl|libwww-perl (<6.02), libio-socket-ssl-perl',
+    'LWP::Protocol::https' => 'liblwp-protocol-https-perl|libwww-perl (<<6.02), libio-socket-ssl-perl',
+    'HTTP::OAI'            => 'libhttp-oai-perl (>= 3.2), libhttp-oai-perl (<< 4.0)',
+    'IO::Socket::IP'       => 'perl-modules (>= 5.20.0) | perl-modules-5.22 | perl-modules-5.24 | libio-socket-ip-perl',
+    'Swagger2'             => 'libswagger2-perl (>= 0.59)',
+    'Mojolicious'          => 'libmojolicious-perl (>= 6.0)',
 );
 
 # These are packages we're going to ignore
@@ -38,7 +41,7 @@ my %ignore = (
 
 my $deps = $C4::Installer::PerlDependencies::PERL_DEPS;
 
-my $prefix = "^/usr/((lib|share)/perl5|(lib|share)/perl/[0-9.]+)";
+my $prefix = "^/usr/((lib|share)/perl5|(lib|share)/perl/[0-9.]+|(lib|share)/.*-linux-gnu.*/perl/[0-9.]+|(lib|share)/.*-linux-gnu.*/perl5/[0-9.]+)";
 
 foreach my $module ( keys %$deps ) {
     next if $ignore{$module};
@@ -68,6 +71,8 @@ foreach my $module ( keys %$deps ) {
         foreach my $pkg (@lines) {
             print " | " if ( $pkg ne $lines[0] );
             print "$pkg";
+            print " | $pkg" . "-5.22" if ( $pkg eq "perl-modules" );
+            print " | $pkg" . "-5.24" if ( $pkg eq "perl-modules" );
         }
         print "\n";
     }